网上彩票购买

码迷,bjsfhd.cn
网上彩票购买 > Windows程序 > 详细

windows下安装torchvision报错的解决方案

时间:2018-08-25 00:39:39      阅读:2470      评论:0      收藏:0      [点我收藏+]

标签:cond   分享   记录   没有   down   模块   最低版本   直接   解决   

今晚再次多次尝试在win10下安装pytorch以及torchvision,终于把上次的坑给填了。来来回回装卸各种包有几十遍了,稍微记录一下,给后面遇到同样问题的人一点提醒。
首先,介绍下安装流程,比较简单,在Anaconda Prompt下运行如下官方指定命令。(这里用pip装,pytorch也可以用conda装,没什么区别,但torchvision只能用pip装,原因下面有说)

pip3 install http://download.pytorch.org/whl/cpu/torch-0.4.1-cp36-cp36m-win_amd64.whl 
pip3 install torchvision

上次的坑主要是:安装都成功了,并且import torch也没问题,但是在import torchvision的时候,出现了如下所示的错误信息:DLL load failed:找不到指定模块。
技术分享图片
首先,我们得知道torchvision在conda里是装不了的,因为根本没有提供给win的资源,因此我们只能使用pip安装。
技术分享图片
安装完后,我们发现torchvision其实是有环境依赖的,其中有一条就是pillow的版本,而此次出错的问题主要就是这个PIL的问题。
技术分享图片
我在网页上找资料的时候,没有找到直接的解决办法,但是有个博主在使用cv这个包的时候遇到了和我差不多的问题,最后他是通过把Pillow包的版本降到4.0.0后得以解决,因此我试着模仿,发现安装torchvision的时候自动给我更新到5.2.0,最后我试着把版本降回到4.1.1,也就是能够成功安装的最低版本,竟然得以解决。

pip uninstall Pillow
pip install Pillow==4.1.1

因此最后得出的结论是:最新的Pillow包缺少了支持torchvision的东西,大家在遇到相同问题的时候,不妨把Pillow的版本降一降,希望能有所帮助。>.>

windows下安装torchvision报错的解决方案

标签:cond   分享   记录   没有   down   模块   最低版本   直接   解决网上彩票购买   

原文地址:https://www.cnblogs.com/yhcheer/p/9532399.html

(0)
(1)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
           
© 2014 bjsfhd.cn 版权所有 京ICP备13008772号-2
迷上了代码!
网上彩票购买 彩票购买 秒速彩票投注 手机彩票app 秒速彩票投注 手机彩票app 手机彩票app 彩票购买 彩票购买 彩票购买